Main (#1) - Install OpenPLM and Joomla - SOLVED (#33) - Message List

Install OpenPLM and Joomla - SOLVED
 unsolved

hi.. I have succeed to install OpenPLM by followed  http://wiki.openplm.org/docs/dev/en/admin/ht_1_install_server.html (This is nice PLM project, thanks to poeple that work on there)

But after that I cannot access my joomla site, Any suggestion please?? thanks before...

  • Message #108

    Hi,

    You should put your configuration inside a virtual host:

    • create the file /etc/apache2/sites-available/openplm
    • add the following lines to this file (replace domain.tld with your domain)
      <VirtualHost *:80>
              ServerName "openplm.domain.tld"
              DocumentRoot "/var/www/openplm"
              WSGIDaemonProcess "openplm.domain.tld" display-name=%{GROUP}
              WSGIProcessGroup "openplm.domain.tld"
      WSGIScriptAlias / /var/django/openPLM/apache/django.wsgi
      # required to enable webdav access
      WSGIPassAuthorization On
      <Location /media/thumbnails>
          WSGIAccessScript /var/django/openPLM/apache/access_restricted.wsgi
      </Location>
      Alias /media /var/django/openPLM/media
      <Directory /var/django/openPLM/media>
          Order deny,allow
          Allow from all
      </Directory>
      </VirtualHost>
      
    • edit /etc/apache2/httpd.conf and remove the content related to openplm
    • run a2ensite openplm
    • restart apache

    OpenPLM should be available on " http://openplm.domain.tld" and " http://domain.tld" should link to joomla .

    Documentation on virtual hosts:  http://httpd.apache.org/docs/2.2/en/vhosts/name-based.html

     http://opensourcehacker.com/2010/05/31/how-to-install-joomla-on-your-ubuntulinux-server-with-basic-security/ shows an example of a joomla virtual host

    • Message #109

      thanks for reply... I have followed your suggestion... but i when i open  http://openplm.localhost , firefox said Server not found

      this is my openplm file

      <VirtualHost *:80>
              ServerName "openplm.localhost"
              DocumentRoot "/var/django/openPLM"
              WSGIDaemonProcess "openplm.localhost" display-name=%{GROUP}
              WSGIProcessGroup "openplm.localhost"
      WSGIScriptAlias / /var/django/openPLM/apache/django.wsgi
      # required to enable webdav access
      WSGIPassAuthorization On
      <Location /media/thumbnails>
          WSGIAccessScript /var/django/openPLM/apache/access_restricted.wsgi
      </Location>
      Alias /media /var/django/openPLM/media
      <Directory /var/django/openPLM/media>
          Order deny,allow
          Allow from all
      </Directory>
      </VirtualHost>
      

      btw i can access my joomla site. (sorry i dont know everything about apache)

      thanks

      • Message #110

        Hi,

        Can you post the output of the commands:

        • apache2ctl configtest (as root)
        • ls -l /etc/apache2/sites-enabled
        • ls -l /var/django/openPLM/apache/

        By the way, I'm not sure that virtual hosts works with the localhost domain. You can try to add a host (like openplm.domain.local) to your /etc/hosts file and set this host as the ServerName.

        • Message #111

          this...

          UNSIPEL-CNC1 ~ # apache2ctl configtest
          apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
          Syntax OK

          UNSIPEL-CNC1 ~ # ls -l /etc/apache2/sites-enabled
          total 0
          lrwxrwxrwx 1 root root 26 Oct 18 10:27 000-default -> ../sites-available/default
          lrwxrwxrwx 1 root root 26 Nov 10 08:12 openplm -> ../sites-available/openplm

          UNSIPEL-CNC1 ~ # ls -l /var/django/openPLM/apache/
          total 12
          -rw-r--r-- 1 root root 1098 Jul 23 22:40 access_restricted.wsgi
          -rw-r--r-- 1 root root 1172 Jul 23 22:40 access.wsgi
          -rw-r--r-- 1 root root  468 Oct 23 13:40 django.wsgi
          UNSIPEL-CNC1 ~ #

          • Message #112

            It seems right.

            You should try to add a host: edit the file /etc/hosts and add the line 127.0.0.2 openplm.home (do NOT remove the other lines).

            Then edit the file /etc/apache2/sites-available/openplm and replace the server name to "openplm.home".

            Restart apache, and open  http://openplm.home/home/, openPLM should be available.

            • Message #113

              Hi...pcosquer....

              thanks alot.... now i can open my joomla site and openplm. then i will try to explore openplm deeper.

              thanks again...

Attachments

No attachments created.