Main (#1) - OpenPLM with django 1.4 in debian testing - SOLVED (#35) - Message List

OpenPLM with django 1.4 in debian testing - SOLVED
 solved

Hi, I'm have a server with debian testing. I tried to install openplm, but I had problems with the django version. When running it gives me import errors, with csrf.middleware. What are the recommended steps to follow? Is there a replacement to these functions in the new api?

Thanks a lot for your help and ideas.

  • Message #118

    Hi,

    OpenPLM is not yet compatible with django 1.4.

    You can install django 1.3 using pip: pip install 'django<1.4'

    Regards,

    Pierre

    • Message #119

      Thanks that made it. It runs ok now, except for the "Browse" button, which exits with this error

      DatabaseError at /browse/object/
      syntax error at or near ")"
      LINE 1: ...e" WHERE ("plmapp_documentfile"."document_id" IN () AND "plm...
                                                                   ^
      

      Maybe it is a configuration error. I will keep trying, thanks for your help

      • Message #120

        Hi,

        This bug (#145) has been fixed but the 1.1.1 release does not contain the fix.

        You can get the latest 1.1 version from subversion:

        • grab the code: svn co svn://openplm.org/openPLM/branches/1.1/openPLM openPLM-1.1
        • replace plmapp and apps directories with the ones from openPLM-1.1
        • service apache2 restart && service celeryd restart

        Or you can just create a document and the browse page should not raise this error.

        • Message #121

          Great! that was very helpful! Thanks!

Attachments

No attachments created.