Main (#1) - MySQL (#86) - Message List

MySQL
 unsolved

I am having several issues with openPLM. One of which is using MySQL. I unfortunately could not get PostgreSQL to work properly, nor am i familiar with it. MySQL is a much better choice for me. I have managed to do database migrations successfully and even (somewhat successfully) create objects. However when i go to Browse on the web interface, it spits out a nice error:

"This version of MySQL doesn't yet support 'LIMIT & IN/ALL/ANY/SOME subquery'

I am running 5.5.43 (the current version in the Ubuntu repositories for 12.04.) If it would help i could update to 14.04 and install 5.6 but my feeling is that it is something supported by Postgre but not My.

I can deal with Python fixes but am not that skilled with it.

  • Message #243

    For your information, openPLM is based on Django and use to Django's ORM (Object-relational mapping) to exchange with databases.

    You can google "django This version of MySQL doesn't yet support 'LIMIT & IN/ALL/ANY/SOME subquery" and you'll find several topics which mention the issue.

    It should comes from an openPLM query which could be improved.

    Could you give more details and screenshots ?

Attachments

No attachments created.