Main (#1) - access problem (#87) - Message List

access problem
 unsolved

Hello, I am new in this forum. I try to get access at the openPLM user surface. If I contact openPLM with  http://’name of my server’/admin/sites/site/1/ I get an error, that I haven’t rights for this page. I checked the attitudes of settings.py for the BROCKER_PASSWORD, but I cannot find wrong settings. BROCKER’s password is the same like rabbitmqctl add_user openplm 'my password'.

What can I do for this problem?

  • Message #248

    Hi fortiss-

    A couple things come to mind- the first is that at that step in the installation, you probably do not have your site name tied to your IP address yet. Try it with your server's IP address in place of 'name of my server.'

    The second is that BROKER_PASSWORD is what Celery uses to access RabbitMQ- not what you use to log into the site. You will need to use the special user named 'company' login/password you created in the step "Create the database."

    If you cannot access the site through the url you mentioned, you can edit the site name directly by opening openplm.conf in the /etc/apache2/sites-available directory and adding the line 'ServerName? (your server)' That should tie the name of the site to the IP. Once you've done that, you can rerun a2ensite openplm, and restart your apache service.

    If that works for you, you can skip the 'Editing the site address' step, and move on.

    Regards, Jesse

    • Message #249

      I changed the name at file openplm.conf to '192.168.0.26'. Futhermore I changed Broker's password at settings.py. But I have no access still.

      At the pictures you can see my attitudes and the browser message.

       http://www.directupload.net/file/d/4099/xzzpd2gn_jpg.htm  http://www.directupload.net/file/d/4099/jao62wp5_jpg.htm  http://www.directupload.net/file/d/4099/846c5ryk_jpg.htm  http://www.directupload.net/file/d/4099/usuc8z4l_jpg.htm

      • Message #250

        Hello,

        I didn't go deeply in your problem but you could start modifying the ALLOWED_HOSTS constant in settings.py file like this :

        ALLOWED_HOSTS = ["*",]
        

        You wrote

        BROCKER’s password is the same like rabbitmqctl add_user openplm 'my password'.

        I think you're correct, please, modify settings.py accordingly.

        Regards, -- Philippe

        • Message #251

          I changed ALLOWED_HOSTS to ["*",] and I tried BROKER_PASSWORD with company's password and openplm's passwort (vhost user). But nothing changes my problem.

          • Message #252

            I see the surface of openPLM if I use the common ‘sudo python manage.py runserver’ at the local machine. But I cannot find the side with my attitudes from openplm.conf at another computer. If I use the adress 'localhost' or name of virtualhost I see the file /var/www/html/index.html . What I have to change at the apache2 attitudes?

Attachments

No attachments created.