Ticket #194 (infoneeded_new defect)

Opened 6 years ago

Last modified 6 years ago

Problems after instalation

Reported by: mauricio.costa Owned by:
Priority: minor Milestone:
Component: models & controllers Version: 1.2
Keywords: Cc:

Description

Very nice software you have. Next step for me is to validate using my company data.

bug description

I installed openPLM following the tutorial, but had no success on Ubuntu 13(x64). So, I tried to reinstall (from scratch), but installing all compatible versions listed on documentation (Minus Ubuntu).

After instalation, I got this error, when typing  http://localhost on my browser:

ImportError? at /
cannot import name abbrtask
Request Method: GET
Request URL:  http://localhost/
Django Version: 1.3.7
Exception Type: ImportError?
Exception Value:
cannot import name abbrtask
Exception Location: /usr/local/lib/python2.7/dist-packages/djcelery/admin.py in <module>, line 19
Python Executable: /usr/bin/python
Python Version: 2.7.4
Python Path:
['/usr/lib/python2.7',

'/usr/lib/python2.7/plat-x86_64-linux-gnu',
'/usr/lib/python2.7/lib-tk',
'/usr/lib/python2.7/lib-old',
'/usr/lib/python2.7/lib-dynload',
'/usr/local/lib/python2.7/dist-packages',
'/usr/lib/python2.7/dist-packages',
'/usr/lib/python2.7/dist-packages/PILcompat',
'/usr/lib/python2.7/dist-packages/gtk-2.0',
'/usr/lib/pymodules/python2.7',
'/usr/lib/python2.7/dist-packages/ubuntu-sso-client',
'/usr/lib/python2.7/dist-packages/ubuntuone-client',
'/usr/lib/python2.7/dist-packages/ubuntuone-control-panel',
'/usr/lib/python2.7/dist-packages/ubuntuone-storage-protocol',
'/var/django/',
'/var/django/openPLM']

Server time: Sun, 28 Apr 2013 17:07:12 -0300

Summary

Environment

  • Version/SVN revision:
  • Browser: Chromium and Firefox
  • Operating system: Ubuntu 13 x64

Steps to reproduce this issue

I have no svn installed and I changed locale to en_US on tutorial

Change History

comment:1 Changed 6 years ago by pcosquer

Hi,

It seems to be a bug related to django-celery (see  https://github.com/celery/django-celery/commit/6eb63a86f58ea099e8925ea70419570498b76ab7 ). You can reinstall django-celery and celery. OpenPLM 1.2 (and OpenPLM 1.3) should be compatible with celery 2.5.5 and django-celery 2.5.5.

To reinstall celery and django-celery (you may have to uninstall python-celery and python-django-celery packages)

pip install -U 'celery==2.5.5' 'django-celery==2.5.5'

comment:2 Changed 6 years ago by pcosquer

  • Status changed from new to infoneeded_new

comment:3 Changed 6 years ago by pjoulaud

  • Priority changed from major to minor
  • Status changed from infoneeded_new to new
  • Milestone OpenPLM 1.3 deleted

No feedback from issuer. Swith from major to minor.

comment:4 Changed 6 years ago by pjoulaud

  • Status changed from new to infoneeded_new
Note: See TracTickets for help on using tickets.